Yeti 2.2.X + MtoA 2.0 + Arnold 5.0

macOS specific questions.
Post Reply
User avatar
AKTegene
Posts: 9
Joined: December 13th, 2017, 3:00 pm

Yeti 2.2.X + MtoA 2.0 + Arnold 5.0

Post by AKTegene »

Hi there,

I'm struggling quite a bit to get any of the versions of yeti past 2.2.0 to show up in Arnold renders.

Code: Select all

Error: [mtoa.translator]   pgYetiArnoldMaya: Arnold node type pgYetiArnold does not exist.
I have ecosystem setup and running properly and I can run all versions prior to 2.1.15 just fine.

The code

Code: Select all

eco -t maya2017,yeti2.1.15,mtoa1.4.1,arnold4.2.16 -r maya
or it's bash script equivalent

Code: Select all

export MAYA_MODULE_PATH=/base/sw/peregrinelabs/Yeti-v2.1.15_Maya2017-darwin64:/base/sw/solidangle/mtoa_2017_1.4.1.2
export ARNOLD_PLUGIN_PATH=/base/sw/peregrinelabs/Yeti-v2.1.15_Maya2017-darwin64/bin:/base/sw/solidangle/mtoa_2017_1.4.1.2/shaders
export ARNOLD_PROC_PATH=/base/sw/peregrinelabs/Yeti-v2.1.15_Maya2017-darwin64/bin
export MTOA_EXTENSIONS_PATH=/base/sw/solidangle/mtoa_2017_1.4.1.2/extensions:/base/sw/peregrinelabs/Yeti-v2.1.15_Maya2017-darwin64/plug-ins
export DYLD_LIBRARY_PATH=/Applications/Autodesk/maya2017/Maya.app/Contents/MacOS:/base/sw/solidangle/Arnold-4.2.16.1-darwin/bin:/base/sw/solidangle/mtoa_2017_1.4.1.2/bin:/base/sw/peregrinelabs/Yeti-v2.1.15_Maya2017-darwin64/bin
/Applications/Autodesk/maya2017/Maya.app/Contents/MacOS/maya
gives me a working version of Maya 2017 with all the plugins working together.

However, setting the environment variables in .mod files didn't work out of the box without the libmtoa_api.dylib symbolic link hack which i'm not in fond of.

Coming to Yeti 2.2.0 and above running

Code: Select all

eco -t maya2017,yeti2.2.0,mtoa2.0.2,arnold5.0.1 -r maya
or its bash script equivalent

Code: Select all

export MAYA_MODULE_PATH=/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64:/base/sw/solidangle/mtoa_2017_2.0.1.1
export ARNOLD_PLUGIN_PATH=/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64/bin:/base/sw/solidangle/mtoa_2017_2.0.1.1/shaders
export ARNOLD_PROC_PATH=/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64/bin
export MTOA_EXTENSIONS_PATH=/base/sw/solidangle/mtoa_2017_2.0.1.1/extensions:/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64/plug-ins
export DYLD_LIBRARY_PATH=/Applications/Autodesk/maya2017/Maya.app/Contents/MacOS:/base/sw/solidangle/Arnold-5.0.1.1-darwin/bin:/base/sw/solidangle/mtoa_2017_2.0.1.1/bin:/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64/bin
export PATH=/Applications/Autodesk/maya2017/Maya.app/Contents/bin:/base/sw/solidangle/Arnold-5.0.1.1-darwin/bin:/base/sw/solidangle/mtoa_2017_2.0.1.1/bin:/base/sw/peregrinelabs/Yeti-v2.2.0_Maya2017-darwin64/bin:${PATH}
/Applications/Autodesk/maya2017/Maya.app/Contents/MacOS/maya
results in maya bouncing in the dock and never launching unless libadlmint.dylib is removed from both MtoA/bin and Arnold/bin. Once removed, Maya launches with all plugins loading and behaving fine but Arnold doesn't pick up the yeti fur.

I have attached my .env files. If anyone out there has any version of Yeti 2.2.X working with Arnold 5.0 please, please, please share how you have set it up.

I've tried this on MacOS 10.10 and 10.13

Thanks so much!
Attachments
envFiles.zip
(2.56 KiB) Downloaded 66 times

User avatar
AKTegene
Posts: 9
Joined: December 13th, 2017, 3:00 pm

Re: Yeti 2.2.X + MtoA 2.0 + Arnold 5.0

Post by AKTegene »

Just turned down the project which justified a license purchase. This has been very disappointing to say the least.

Post Reply