Problems with V-ray rendering

Questions related to integrating and using Yeti with Chaos Group's VRay.
Post Reply
muneto_bm
Posts: 2
Joined: November 19th, 2021, 9:53 pm

Problems with V-ray rendering

Post by muneto_bm »

Hello.
I'm trying to use Yeti 4.0.4 with Maya2020 V-ray 5.10.
I set the environment variables and when I render in Maya it doesn't crash, but it gives me an error and won't render the hair.
Can you please help me?

Maya2020.4
V-ray5.10.22
Yeti4.0.4

Image 2.jpg is Maya.env.

Best regards.
Attachments
2.jpg
2.jpg (223.32 KiB) Viewed 93 times
1.jpg
1.jpg (231.07 KiB) Viewed 93 times

muneto_bm
Posts: 2
Joined: November 19th, 2021, 9:53 pm

Re: Problems with V-ray rendering

Post by muneto_bm »

It's solved for now.

The installation guide says
"Please note, if you are installing on Windows you will also need to add the Yeti bin directory to your global PATH environment variable. ".
but all other environment variables are listed in Maya.env.

However, when I checked the environment variables in Maya Script editor, I found that VRAY_FOR_MAYA2020_PLUGINS was not reflected.
So I also set VRAY_FOR_MAYA2020_PLUGINS as a global PATH environment variable.
Now we are ready to render.

Also, I removed the paths that were "plug-ins" in the back.

Thank you very much.

User avatar
colin
Site Admin
Posts: 2233
Joined: December 15th, 2012, 10:11 am
Location: Ontario, Canada
Contact:

Re: Problems with V-ray rendering

Post by colin »

We don't actually stipulate where the environment variables should be set, this is generally left up to each individual studio. Ultimately using the system environment variables is best as Maya.env only sets the Maya local environment and the rendering extensions may/may not use this.

Post Reply